#define buffer_busy(bh) (atomic_read(&(bh)->b_count) | ((bh)->b_state &
BUFFER_BUSY_BITS))
surely, it should be:
#define buffer_busy(bh) (atomic_read(&(bh)->b_count) || ((bh)->b_state &
BUFFER_BUSY_BITS))
i.e. logical OR instead of bitwise.
Shouldn't it?
-Steve Ellmore
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/