This looks really good, I'd like to see something like that merged soon!
Some comments:
- please move the sector_t typedef from <linux/types.h> to <asm/types.h>,
so 64 bit arches don't have to have the CONFIG_ option at all, some
32bit plattforms that are unlikely to ever support large disks
(m68k comes to mind) can make it 32bit unconditionally and some like
i386 can use a config option.
- sector_div should move to a common header (blkdev.h?)
And something related to general sector_t usage:
- what about sector_t vs daddr_t? Linux still has daddr_t, but it is
still always 32bit, I think a big s/sector_t/daddr_t/ would fit the
traditional unix way of doing disk addressing
- why is the get_block block argument a sector_t? It presents a logical
filesystem block which usually is larger than the sector, not to
mention that for the usual blocksize == PAGE_SIZE case a ulong is
enough as that is the same size the pagecache limit triggers.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/