I'd suggest to stay with one coding style. Prefferedly that would be
the one in Documentation/CodingStyle.
> +
> + reservedpages = 0;
> + for (pfn = 0; pfn < max_low_pfn; pfn++)
> + /*
> + * Only count reserved RAM pages
> + */
> + if (page_is_ram(pfn) && PageReserved(mem_map+pfn))
> + reservedpages++;
Adding braces around this hughe loop body would make it a little
more readable..
Besides these minor style nitpicks the pages look good to me.
BTW: Where is the NUMA code that builds ontop of this?
Christoph
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/