> code that is totally correct, and that it would make _no_ sense in
> writing any other way.
The code is correct, but if one is adding explicit types, for clarity
and to avoid introducing bugs, then I think that code like this is
exactly where they most belong:
if ((size_t) len <= sizeof(short) || (size_t) len > sizeof(*sunaddr))
If that prevents one person from later writing buggy code like:
if ((size_t) len <= sizeof(short))
then it's a Good Thing.
-- David desJardins
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/