Looks good :)
> The only difference between your and my tree now is the PCI_MAX_DMA32
> flag. Would you consider this? I already use this flag in the block
> stuff, I just updated the two references you had. Maybe
> PCI_MAX_DMA32_MASK is a better name.
>
> I didn't put it into my patch becuase there is no way you can
> use such a value in generic code.
>
> What if my scsi controller's pci DMA mask is 0x7fffffff or something
> like this? You don't know at the generic layer, and you must provide
> some way for the block device to indicate stuff like this to you.
Then your SCSI controller will not use PCI_MAX_DMA32 but rather that
particular mask? For block drivers, using 0x7fffffff for
blk_queue_bounce_limit is perfectly fine too.
> That is why PCI_MAX_DMA32, or whatever you would like to name it, does
> not make any sense. It can be a shorthand for drivers themselves, but
> that is it and personally I'd rather they just put the bits there
> explicitly.
Drivers, right. THe block stuff used it in _one_ place -- the
BLK_BOUNCE_4G define, to indicated the need to bounce anything above 4G.
But no problem, I can just define that to 0xffffffff myself.
> I am just finishing up the "death of alt_address" patch right now.
Excellent.
-- Jens Axboe- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/