I think the new-style sg_list is slightly overkill, too much
stuff. You need much less, in fact, especially on x86.
Take include/linux/skbuff.h:skb_frag_struct, rename it to
sg_list and add a dma_addr_t. You should need nothing else.
The bounce page, for example, is superfluous.
If you bounce, the bounce page can be determined later via the
dma_addr_t right?
And Dave, should I add the 64-bit stuff I started again? :-)
Let me draft something up, and meanwhile you can think about
the changes I suggest above. Ok?
Later,
David S. Miller
davem@redhat.com
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/